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7 Charts
Now we get to something most people find enjoyable. We will create charts. Long data series and tables 
can be extremely tedious to watch, and you can often make data more readable by visualizing them in 
a chart instead. Excel offers lots of possibilities to make some really nice graphs that can illustrate many 
different types of data. 

In this book, we must first make a bar chart. The bar chart will be the basis for a series of exercises where 
we work with the various options and other things you can do with a chart. Then the other chart types 
will be described in outline, so you can experiment with adjusting them.

3D charts will not be reviewed in this book, because it is something you can easily figure out yourself 
once you have learned the basics of bar, basket and pie charts. 3D charts are beautiful and can really 
impress, but you should also be aware that they may be harder to read accurately. However, in a sales 
brochure are they do look good!

7.1 Bar Charts

To get started with charts, we need some data to work with. Create a spreadsheet similar to the one 
shown in Figure 91. We will use this spreadsheet for the next several exercises.

The spreadsheet is an energy accounting, which shows a random English family’s consumption of 
heating oil and electricity over a year. The data are entirely fictional, and the task is not to come to any 
conclusions about the family’s total CO2 emissions!

Figure 84: The spreadsheet we will use for our chart exercises.
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Let us get started on our first chart! We need to make a bar chart”. 

1. Make sure one of the cells in the table is the active cell. Alternatively you can select the 
whole table.

2. Choose the Insert Tab in the Ribbon.
3. Click on the Bar button.
4. Choose chart type top left (see Figure 85).
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Figure 85: Choose your first chart.

Within a few seconds the miracle will happen. If you have followed my instructions correctly, you already 
have a neat chart ready for use. The graph has a horizontal axis with months and a series of bars in two 
different colours that show the oil and electricity consumption respectively.

Figure 86: Your first bar chart. Notice the Ribbon has changed.

Unless you clicked on an empty cell in the spreadsheet, the chart will now be selected. If not, click one 
time with the mouse on the chart.

When a chart is selected, certain things happen. The table with data will be highlighted, so you can see 
which data are included in the chart. You can change the data to be included by pulling with the mouse 
at the corners of the selection.
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7.1.1 Charting Tools and Language Confusion

When the chart is selected, some Tabs will be added to the band called “Charting Tools”. The Charting 
Tools contain all the functions you can use on your charts. The tools are organised into three Tabs called 
Design, Layout and Format. 

The Ribbon is a brand new way to use charts, and once you get used to it, it is a definite improvement 
on the endless number of dialog boxes in the older versions.

The Design Tab contains the basic functions to adapt the structure of the chart. Think of design as being 
about the basic structure without the colours, numbers formats, etc. It could be about what type of chart 
you want to use, the data to be included and how they should be interpreted. It can therefore be a little 
confusing that in the Design Tab we can select what colour Styles to match with the colour theme you 
have set for the spreadsheet.

The Layout Tab contains functions to manage the various elements of a chart.  A chart can, for 
example,  include a title, an explanation for the different column colours, gridlines, which helps make 
the chart easier to read, layout, etc. Thus layout is about the placement of the different elements that 
you can “stick” on a chart.

The Format Tab contains functions relating to the aesthetic part of the task, such as colouring, font, 
number formats etc.

7.1.2 Terminology – What does it mean?

There is some terminology and words and concepts you should know before you start working with 
charts. Figure 87 shows the chart from our exercise, with a few extra features added. 

Figure 87: The most important elements in a chart.
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“Data Series” is the name for the data displayed in the form of pillars. In this example we have two data 
series, namely “Oil in litres” and “Electricity consumption in kWh.

Everything can be adjusted in the chart. If you right-click an item a menu pops up where you can do 
different things. One detail is the data series.  If you just right-click on a pillar in the data series, the 
changes you make affect the entire data series. However, if you click twice with the left mouse button 
on a pillar and then right-click, the changes will affect only the column you clicked.

7.1.3 Change of Scale

By default, Excel will adjust the scale of value axis. But sometimes it can be advantageous to create a fixed 
scale. This is especially true if you have two charts side by side, which must be comparable. If you make 
permanent scales on both charts, they are easy to compare. Another example is if you have a percent 
scale. Excel has a tendency to let it go up to 120%, although you might only want it to go to 100%.

1. Click with the right mouse button on one of the figures on the value axis.
2. A menu appears, and you must click on Format axis.
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Figure 88: Axis Settings.

The dialog box “Format Axis” will open, and here you can set a lot of different things. You can include 
adjustable scale, colour and number formats, among other things.

In the left side of the box the settings are saved under different categories.

3. Ensure the category Axis Settings is chosen.

Here you can set the scale on the axis. In this case we will just change how high the scale goes.

4. At “Maximum” select Static instead of Automatic.
5. You can now type in the field to the right, and there you must type 400.
6. Click Close.

Your chart has now changed. The scale was smaller, and your columns became taller as a result. Some 
of them are so tall that they grow out of the chart
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Figure 89: The chart with a different scale.

This is the risk of having a fixed scale, so you should think carefully before you choose this option.

7. We will also use the chart in the next exercises. So, right-click the value axis again, click on 
Format Axis and change the scale to Automatic again.

Two Value Axes Each with its Own Scale

In some cases it might be a good idea to have two different value axes. In our diagram we show the oil 
and electricity consumption in the same chart, and both datasets use the same value axis. The figures 
for oil and electricity are rather close to each other, so in our chart it is not a problem, but one is not 
always so lucky 

In many apartments heat consumption is calculated by counters located on the radiators. Many know 
this system as counting “units”, and you might only use 50 units a month instead of 300 litres of oil.

In our chart it would cause problems, since the columns of heat would be very short and difficult to 
compare month for month.

1. For the next exercise, I ask you to change the data form, so it will look like Figure 92. 
The title “Oil in Litres” must be changed to “Heat Units”, and the figures must also be 
changed. The chart adapts automatically.
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We need a new axis for the heat units, since the columns are a little too short to look proper.

2. Click on one of the value columns.
3. In the Ribbon, choose the Layout Tab, then click on the Format Selection button, located 

to the far left on the Ribbon.

Figure 90: The Format Selection button.

This gives you the option to change all kinds of setting for the “Heat Units” data series.
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Figure 91: Series Settings.

You can experiment with fill colour, border colour and shadows when we are done with the exercise.

4. Ensure Series Settings is selected in the left side of the box.
5. Under “Plot series on”, select Secondary Axis.
6. Click on Close.

Figure 92: The chart with a secondary axis.
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Now the chart looks like the chart in Figure 92 There is an additional scale on the right side, but there 
are also some less fortunate things. The scale of heat units is correct, but Excel has decided that the blue 
bars now should be located on top of the red bars. This means that there are some red bars that you 
cannot see because they are shorter than the blue ones! This was not what we asked for. All we wanted 
was an extra axis.

Things like that happen occasionally in even the best programs.  We have actually found an error in 
Excel! As I prepared this exercise, I tried various tricks to rectify the error, but Excel insists that, when 
you have two value axes, the columns stand on top of each other.

But where there is a will there is a way.  Sometimes you have to be creative and find an alternative 
solution. We will therefore turn the chart into a “line chart” in the next section! 

7.2 Line Charts

Line charts works exactly like bar charts, but instead of pillars to visualize values Excel creates points 
connected by lines. 

We continue where we left off in the last exercise. The exercise went wrong because we found an error 
in Excel. Therefore we will begin this section by turning a bar chart into a line chart. 

1. Click somewhere on the chart.
2. Choose the Layout Tab in the Ribbon.
3. Furthest to the left in the Ribbon there is a grouping of buttons called “Current 

Selection”. The top button is actually a “scroll box” where you can choose between different 
things. You must ensure that it shows “Chart Area”. If it does not, click the small arrow to 
the right and select Chart Area on the list.

This little exercise ensured that you have selected the whole chart and not just a data series, an axis or a 
single bar. When we change the chart type for the entire chart, the entire chart must be selected. Later, 
we will try to make a combined chart.

4. Choose the Design Tab in the Ribbon.
5. Click on the Change Chart Type to the far left in the Ribbon.
6. Choose the Line category in the left side of the box that opens up.
7. In the right side of the box, click on the first chart in the row beneath the headline “Line” 

(see Figure 93).
8. Click on OK.
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Figure 93: The line charts are located in the Line category.

You have now transformed the entire chart into a line chart. The disadvantage is that the settings are 
now reset again, so you no longer have a secondary axis. If you like, you can put a secondary axis in 
again. It should look like this: 
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Figure 94: line chart with two axes.

7.3 Charts with both Columns and Lines

You are not limited to either bar charts or line diagrams. In Excel, you can actually both have your cake 
and eat it!

You can select a chart type for each data series. However, that only makes sense when the chart types 
are compatible. It makes no sense to combine a line chart with a pie chart, as we shall see later.

We will now change the line chart back to a column chart.

1. Click on a place in the line for electricity consumption.
2. In the Ribbon, Click the Design Tab.
3. To the left in the ribbon, click the Change Chart Type button.
4. In the box that opens, choose Column in the Category list to the left.
5. Now click on the first column chart in the right side.

When you select a single data series, it will be the only data series that is turned into another chart type.

Figure 95: Combine line and bar chart.

In the next section, we will work with some other chart types. If you like, you can proceed with bar and 
line charts and find out how to add colour and effects. 
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7.4 Circle Charts

Circle charts, also called pie charts, are useful to describe the size of different values in relation to each 
other. Unlike bar and line charts, pie charts are not suitable for describing your electricity consumption 
over time. 

To perform the next exercise you must create a spreadsheet in the same way as in Figure 96. The 
spreadsheet is a simplified monthly budget for a family’s recurrent expenditures.

Figure 96: Starting point of the exercise.

In a pie chart, we can illustrate what the costs are compared to each other.

When the spreadsheet is ready, you must activate one of the cells in the table.

1. Click on the Insert Tab in the Ribon.
2. Click on the Circle Tab in the Ribbon.

Figure 97: The Circle Tab.

3. Click on the 2-D circle top left in the menu that appears.
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After a brief moment, you have a circle chart where the various items in the budget have become pieces 
in a “pie”.

Figure 98: A circle chart.

As you can probably see, it is a good visual way to illustrate where the money goes. What you cannot 
see is how much money it is. We might also like to add some percentages.
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Figure 99: The Circle chart with data labels.

4. Ensure the chart is selected.
5. In the ribbon, choose the Layout Tab.
6. On the Tab there is a group of buttons called “Labels”. Click on the Data Labels button.
7. A menu appears where you must click on the menu item called Outside.

Now the amounts are plotted in the chart, but it will also be very illustrative to put some percentages 
on them. Some people like pies, while others like numbers better.

8. Right-click on one of the data labels, for instance the one that says “Kr. 10.000,00”.
9. In the menu that appears, choose Format Data Labels.

A box will open where you can set everything concerning the data labels. Like so many other boxes in 
Excel, the options are organised in categories, which you can choose from in the left side of the box.

Figure 100: Format data labels.
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10. Ensure the category Label Settings has been chosen.
11. Under the header “Label Contains”, tick Percentage and leave the others as they are.
12. Click on Close.

Now you have both amounts and percentages in the chart, which gives a lot of inormation about our 
household budget.

Figure 101: Data labels with percentages.

Now I suggest that you experiment a little with your circle chart. Try changing chart type to a 3D pie 
chart. 3D circle charts look good, and unlike bar and curve charts the beautiful effect does not affect 
readability in a circle chart.

7.5 Scatter Charts

Scatter charts are also called “X-Y” charts. If you are a mathematician, you have probably already figured 
out what an X-Y chart does; it shows values of Y as a function of X. Or put another way, you can show 
that some values are dependent on others. 

To be fair, you can also do that in a bar or line chart, but the scatter chart is different. In the bar and line 
charts, the horizontal axis is not a scale, but a “category axis”. It represents fixed points present in the 
data table. Each row of the data table corresponds to a point on the horizontal axis of the chart. In the 
scatter chart, the axis scales in relation to the values appearing in the data table, and the values in the 
data table may not even be ordered. On the downside, you cannot use values such as January, February, 
etc. in a scatter chart. All values must be numbers.

If your values on the horizontal axis are in sorted order and have the same interval such as 10, 20, 30, 
40, etc. you can use an ordinary line chart. But with the scatter chart, the horizontal axis can also assume 
negative values.
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The scatter chart is therefore suitable for displaying results of measurements where, for instance, you 
measure the density of a material in relation to temperature. You may also to some extent use scatter 
charts to show graphs for mathematical functions.

There are features in Excel to show graphs of a mathematical expression, but by creating a table with a 
lot of values for x, and a lot of values for f(x) you can make such a graph nonetheless.

7.5.1 Results of Measurements

In this example, I have made some samples of our consumption of fuel oil for heating the house in 
relation to diurnal temperature outside. The samples are carried out on some random day during the 
autumn of 2007. I have set a table with my measurements and would like to visualise the results with 
a scatter chart. I want to show how much oil we use in relation to outside temperature. The horizontal 
axis should be the temperature, and the vertical axis should be oil consumption in litres.
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1. Make a spreadsheet as shown in Figure 102.

Figure 102: The starting point of the exercise.

2. Select cell region C3:D12. The dates are not relevant in this chart.
3. Click on the Insert Tab in the Ribbon.
4. Click on the Scatter Chart button.
5. In the menu that appears, choose the chart type top left (see Figure 103).

Figure 103 the Scatter Chart button.

We now have a scatter chart with a temperature scale at the bottom and the corresponding oil consumption 
plotted into the graph as points.

Here you can really see the difference between line charts and section charts, since measurements in 
the data table have not been arranged according to temperature. Excel has done that for us in the chart.
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7.5.2 Graphic Representation of Mathematical Expressions

As previously mentioned, you can also use the scatter chart to display graphical representations of 
mathematical expressions.  Excel is not really designed for this and there are other programs better 
suited for this task. 

But for lack of better you can still use Excel.

In our example we will try to show a graph of a second quadratic polynomial, which is a nice parabola. 

The expression we want to display is:

f(x) = 3x2 + 2x – 3

We will try to show the graph for x-values between -7 and +7.

1. Start by creating a spreadsheet as shown in Figure 104.

Figure 104: The starting point for the exercise.

2. In cell C4, write the formula =3*B4^2+2*B4-3, and press ENTER.
3. Copy cell C4 to cell region C4:C18.

Now we have a table with two columns. One column has the X-values and the other has the function 
of the X-values. Now we can create a scatter chart, but this time we choose a chart where the points are 
connected.
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4. Activate one of the cells in the table.
5. In the ribbon, choose the Insert Tab.
6. Click on the Scatter Chart button and choose the chart type top right.

Now we have our parabola.

Figure 105: Excel is not able to draw a parabola, but if we use the program creatively it is possible to get 
around that problem.
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Excel has several types of charts, and there are also three-dimensional versions of the chart types we have 
worked with here. I encourage you to experiment with the different types of chart. Not all possibilities 
are examined in this book, but you are now aware of everything you need to continue on your own.

7.6 Chart Sheet

If you do not want the diagram inside the spreadsheet, you can place it in a separate chart sheet. It will 
then get its own sheet tab at the bottom of the screen.

1. Create a chart in a spreadsheet or use one from a previous exercise.
2. Right-click on the chart and click on the menu item Move Chart
3. In the window that opens. Select New Sheet and name it. In Figure 106, I call the new sheet 

“Parabola”.
4. Click OK.

Figure 106: Move Chart.

The chart disappears from the original spreadsheet, and a new sheet tab has appeared, which in my case 
is called “parabola”. 

7.7 Viewing and Printing

Viewing and printing is perhaps not so important compared to learning how to do spreadsheets, but 
when you start working more seriously with it, you will discover that there are some possibilities that 
are good to know about.

7.7.1 Printing

Of course, you can print your spreadsheets, but often you will find that it requires a little adjustment and 
alignment before you get a satisfactory result. It is not something that should cost you sleep at night, 
because when you have learned a few tricks, it is not a problem. 
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Figure 107: A large table.

In Figure 1017 there is an example of a table that takes up a lot of space. If you like, you can create a 
similar table, so you can practice yourself. Content is not so important as long as you have roughly the 
same number of rows and columns as in the example.
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7.7.2 Print Preview

I always use the “Print Preview” function before I print. “Print Preview” shows what the printout will 
look like when it is sent to the printer.

1. Click on the Office Button, point to the menu item Print, then click on Print Preview. 

Figure 108: The Print Preview function.

Now you will see an image of how the print will look with the current settings.

In our example in Figure 109, it is clear that the transcript is not optimal. The table in the spreadsheet 
has 13 columns, but only seven of them are displayed. If you scroll down with your mouse, you get to 
page 2 where the rest of the table is displayed. 

http://bookboon.com/


Download free eBooks at bookboon.com

Click on the ad to read more

Excel 2007

111 

Charts

Figure 109: The “Print Preview” window, where you can see that the table does not fit on one page.  
In the bottom left corner you can see that the printout takes up two pages.
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7.7.3 Page Setup

We need to change some settings. Fortunately, you can adjust a lot of different things. For instance, you 
can scale down. The content of the spreadsheet must be scaled down so that it fits on one page. You can 
also adjust the margins and add headers and footers, which are text elements that appear at the top and 
bottom of each page of the transcript.

Finally, you can also set the number of rows and columns to be repeated on all pages. It is especially 
helpful if you need to print a table with many rows, since you can view the column headers on all pages 
of the transcript.

2. In the Ribbon, click on the Page Setup button.

The “Page Setup” window opens and from here you can control the various options.

Figure 110: The “Page” Tab.

The window is divided into four different tabs called “Page”, “Margins”, “Header/Footer” and “Sheet”.

In the “Page” Tab you can choose the orientation, ie.  choose between portrait and landscape paper 
format. You can also select the scaling of the content. The default scaling is 100%, but you can adjust it 
up and down manually until you get an outcome that suits you.
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3. In this exercise, let Excel find an appropriate scaling by simply indicating that Excel 
must adapt the content in width and height to a specified number of pages in landscape 
format. In our case we will probably get a suitable result by selecting one page wide by one 
page in height landscape format. 

 Figure 111: Visual setting of margins.

Figure 112: Our table with settings as shown in Figure 110.

It is not always enough to scale the pages to get an appropriate result. Sometimes you need to precisely 
define where the page breaks should be. You will learn that in the next section on “viewing”. 

The “Margins” Tab in the “Page Setup” window is. Of course you can set how big the margins should 
be in centimetres. This can also be done in another way. If you close the window “Page Setup” and set a 
marker at the display margins on the tape, you can adjust the margins visually using the mouse. I think 
this is easier to work with.

The “Header/Footer” Tab allows you to display a fixed text at the top and bottom of each page of the 
transcript. This text could be company name, author, etc. But you can also add some text fields which 
automatically show the date, page number and filename.
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The “Sheet” Tab is used to set what must be printed. You do not always want to print everything, and it 
may be necessary to repeat some rows or columns on all pages. Most settings in this Tab are not available 
if you opened the window “Page Setup” from within “Print Preview”.

Figure 113: The Printout button.

4. Therefore, you must close “Print Preview”.
5. To get into “Page setup” again, click the Page Layout Tab in the Ribbon, then click the Print 

Titles button. It is a bit of a long way to go, but Excel can also be like that sometimes.
6. You can now choose the Sheet Tab again, if you have not already done so. 
7. In Figure 114 I have set Excel to repeat number 1 and column A. This of course does not 

matter if I have already chosen that Excel should adjust everything to one page, but it was 
only meant as an illustration, and we will need it later for an exercise in the Section “View” 
below.

www.sylvania.com

We do not reinvent  
the wheel we reinvent 
light.
Fascinating lighting offers an infinite spectrum of 
possibilities: Innovative technologies and new  
markets provide both opportunities and challenges. 
An environment in which your expertise is in high 
demand. Enjoy the supportive working atmosphere 
within our global group and benefit from international 
career paths. Implement sustainable ideas in close 
cooperation with other specialists and contribute to 
influencing our future. Come and join us in reinventing 
light every day.

Light is OSRAM

http://bookboon.com/
http://bookboon.com/count/advert/ae925238-62e0-4fca-a4f2-a24b0097a136


Download free eBooks at bookboon.com

Excel 2007

115 

Charts

Figure 114: Row 1 and column A are repeated on all pages with this setting.

8. Click OK. 

7.8 Viewing

So far, our exercises have taken place in “Normal View”. This is the standard way to display spreadsheets, 
and it is nicer when you work in the spreadsheet. But there are a few other useful views you can use 
before you print your sheet. 

If you have a large spreadsheet you need to print, the result may well be somewhat disappointing because 
spreadsheets tend to spread out over several pages. In the section on printing, you learned that you can 
scale the printout to fit into a specific number of pages, but you also have the opportunity to control 
exactly where the page breaks should be.

The display buttons are located at the bottom right on the screen. You can get to he same features by 
clicking on the View Tab in the Ribbon, but the display buttons at the bottom are always visible, allowing 
you can save a mouse click. 

The display buttons consist of three buttons and a “zoom slider”. The “zoom slider” works by clicking 
the mouse and dragging to the right or left to zoom in and out respectively. I prefer instead to hold 
down the CTRL key on the keyboard while I scroll up or down with the scroll wheel on the mouse. It 
is a much easier way to zoom in and out, in my opinion, and this method can also be used in many 
Windows programs.
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Figure 115: The display buttons.

The other three view buttons switch between Normal, Page Layout and Show Page Breaks.

We are already familiar with Normal, since it is the view we have been using in all our exercises so far. This 
is the best view when you just have to work with the spreadsheet without caring about the print layout.

Page Layout shows something similar to the result if you print out the spreadsheet. You also get that 
if you choose Print Preview from the Office Button, but in page layout view, you can still work in the 
spreadsheet. However, the view is not nearly as accurate as Print Preview.

Show Page Breaks are the most useful alternative view, since it also adds an important functionality. Here 
you can see and adjust what should and should not be printed. You can insert and rearrange page breaks 
and exclude certain areas from being printed. 

7.9 Adjust Print Range

Figure 116: The view Show Page Break.

1. Clik on the Show Page Break button to display the same screen as in Figure 116.
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In the example in Figure 116, I have changed the page setup from the previous exercise, so 
the scaling is 100% again. Page layout is still landscape format. The repetition of the first row 
and column has also been disabled. 

The table is surrounded by a thick blue border, which defines “printable area”.  Only those 
cells that are in the frame will be printed. You can, by pointing to the frame with your mouse 
and holding the left mouse button, move the frame. That way you can also exclude some of 
the table for printing, if that is what you want.  You can also have several separate areas in 
the spreadsheet as a part of the print area. To illustrate this, it requires that our example be 
extended with a couple of extra tables.

2. Click on the view button Normal, and add a few tables like the ones shown in 
Figure 117. Also add some text in some other cells that you do not want printed.
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Figure 117: Expansion with a few extra tables and a cell area that we do not want printed.

3. Change to Show Page Breaks again.

You can still see that the original table is inside the white area, which means that it will be printed. But 
the new tables are outside the printable area and will therefore not be printed

If you have several different areas in the same spreadsheet that you want printed, you can hold down the 
CTRL key on your keyboard while you select the different areas with the mouse. When you are finished 
selecting fields, click the right mouse button on one of the areas and select the menu item Set Print Area:

4. Hold down the CTRL key while you select all three tables with the mouse. Do not select 
that which you do not want to print. 

5. Right-click on any of the highlighted areas and click the menu item Set Print Area.

We now have a “composite print area” and the spreadsheet will look like Figure 118. 
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Figure 118: Page Breaks View with the new tables in the grey area.

Composite printing areas are an advantage if you only want certain fields written out, for example some 
nice tables and charts. You can have some intermediate calculations in the spreadsheet that you do not 
want in print.

7.9.1 Managing Page Breaks

In our exercise, there is an automatic page break down through the multiplication table. It is signified 
by a dotted blue line. Excel decides where the automatic page breaks should be, and your spreadsheet 
might show something else. It depends on the cell heights and column widths, but it also depends on 
your printer and its configuration.

To gain more control over where the page breaks are, you can insert permanent page breaks. Fixed page 
breaks will not move, and if you put them in the right places, you can avoid unfortunate automatic page 
breaks. 

Insertion of fixed page breaks is always on the left and above the cell which is active. Our multiplication 
table in the example would obviously spread out over two pages. In my spreadsheet the table was divided 
by an automatic page break between the columns for October and November. I would like the shift to 
be between June and July, so I make H1 the active cell. 
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1. In your spreadsheet, activate the cell, where it says “July”. 
2. Make sure the Page Layout Tab in the Ribbon is selected, and click on the Shift button. 
3. In the menu that appears, click on Insert Page Break.

Figure 119: The Shift button.

Now there are no automatic page breaks, and there will not be any unless you make the sheet bigger.

Figure 120: Now the page breaks are fixed.
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